#MOSS 2007 Farm Restore (flag new) SSP login bug

I  had several MOSS 2007 Farm restorations in my test environments. Each time after a restoration SharePoint’CPU goes up to 100% and a lot of errors (6483, 6398, 7076) appear in the Application event log.

The Execute method of job definition
Microsoft.Office.Server.Administration.ApplicationServerAdministrationServiceJob
(ID 538459ed-46a7-47e5-ba80-2a7120c36336) threw an exception.
More information is included below.
Value cannot be null.
Parameter name: userName

It looks like it is the SharePoint Farm restoration process bug. This restoration does not restore ProcessIdenty information for SharedServices provider.

Run the following command, to be sure that we are talking about the same issue: stsadm -o execadmsvcjobs

It should fail.

Run the folowing command after restoration, to fix your farm :

stsadm -o editssp -title SharedServices1 -ssplogin “NT AUTHORITY\NETWORK SERVICE”

or

stsadm -o editssp -title SharedServices1 -ssplogin “DOMAIN\ACCOUNT” -ssppassword ****

First command is suitable for the SingleServer installation.

Run the following command, to be sure that we have fixed the issue:   stsadm -o execadmsvcjobs

It should succeed.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s